Emails not being recieved or sent.

Incident Report for Productboard

Resolved

This incident is now resolved, and email services are working as expected.
Posted Sep 08, 2025 - 20:50 UTC

Investigating

At the moment, customers are not able to receive:
email notification
email invitations
weekly update emails
insights digest emails
Portal Submission emails

We are investigating this issue and will update the status page accordingly.
Posted Sep 08, 2025 - 12:02 UTC
This incident affected: External services ([Email delivery] SendGrid API).