Elevated Latency on Query Engine

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 19:18 UTC

Monitoring

We are currently investigating increased latency in our Query Engine. The issue is caused by a high volume of incoming events originating from a single space.

Impact: Some customers may experience delays in seeing updates or changes reflected on their boards.

We’re working to mitigate the event load and restore normal performance. Updates will be provided as we learn more.
Posted Dec 04, 2025 - 19:08 UTC
This incident affected: Web application (Boards and data).