Unable to Modify Feature Owner, Time Frame, Status, and Releases

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 17:31 UTC

Investigating

We are currently having an issue impacting updates to feature ownership, time frames, status changes, and releases on the data page.
Posted Sep 11, 2025 - 17:21 UTC
This incident affected: Web application (Boards and data).