Delay for some customers when taking actions.

Incident Report for Productboard

Resolved

This incident has now been mitigated.
Posted Jan 21, 2026 - 16:32 UTC

Investigating

Some customers are experiencing a serious delay when taking actions. We are investigating the issue and shall keep you updated here.
Posted Jan 21, 2026 - 16:06 UTC
This incident affected: Web application (Boards and data, Teamspaces).