The issue affecting publicly shared Legacy Roadmaps has been mitigated. We've implemented a solution to address issues accessing and using Productboard. Some customers may have to clear their cookies. If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted Jun 12, 2025 - 20:31 UTC
Identified
We've received reports of related issues accessing Productboard and have identified that the issue affecting Publicly Shared Legacy roadmaps to be connected and is due to a current Cloudflare outage. We're working with Cloudflare to resolve the issue. Please see https://www.cloudflarestatus.com/ for more details.
Posted Jun 12, 2025 - 20:00 UTC
Investigating
We are experiencing an issue that is preventing publicly shared Legacy Roadmap boards from loading. We're currently investigating the issue and will provide a status update once we have more information. Apologies for the inconvenience.