Publicly shared roadmaps are not currently working.
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 15:25 UTC
Monitoring
Roadmaps are now visible on a shared URL; we are monitoring the results.

Thank you for your patience.
Posted Dec 18, 2023 - 12:09 UTC
Investigating
Roadmaps shared via a URL are not currently working. We are investigating this issue and will keep you updated on this page.

Thank you for your patience and understanding during this time.
Posted Dec 18, 2023 - 11:49 UTC
This incident affected: Web application.