Slow performance

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 11:50 UTC

Monitoring

The root cause has been identified and the issue has been mitigated. Performance is currently back to normal and are monitoring it.
Posted Oct 07, 2025 - 09:18 UTC

Investigating

Some users may see intermittent slowness today due to a scheduled Cloudflare network maintenance in Ashburn (IAD) 06:00–10:00 UTC (08:00–12:00 CEST).

Our systems are healthy and we're monitoring.
Posted Oct 07, 2025 - 09:05 UTC
This incident affected: Web application (Boards and data, Teamspaces, Insights and AI, Identity and access).