We're experiencing degraded performance

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 19:09 UTC

Monitoring

A fix has been implemented and we're currently monitoring it.
Posted Nov 18, 2025 - 15:33 UTC

Identified

The issue is identified and we're waiting for a fix.

Productboard remains functional, but you may see very occasional issues with certain elements.

Please, try to refresh the page if you observe any issues.
Posted Nov 18, 2025 - 13:30 UTC

Investigating

We're experiencing degraded performance, which is being investigated.

While the Productboard page still loads, you may be observing occasional issues with loading or opening certain elements.
Posted Nov 18, 2025 - 12:33 UTC
This incident affected: Web application (Boards and data, Teamspaces) and Public roadmaps, Public portals.