Productboard not loading data
Incident Report for Productboard
Resolved
We have now resolved this incident, you can refresh your browser and it should all be working for you.

Thank you so much for your patience today.
Posted Aug 04, 2023 - 13:01 UTC
Investigating
Unfortunately, we are experiencing issues loading data in workspaces. Our team are investigating this issue and we will inform you of the resolutions here.
Posted Aug 04, 2023 - 12:53 UTC
This incident affected: Web application.