Productboard services are partially unavailable.

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 11:30 UTC

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 11:29 UTC

Investigating

We're currently facing issues with some of our services. Specifically, you may temporarily not see Insights boards or Note topic in your workspace. The rest of the app remains functional. The team is currently investigating it.
Posted Apr 14, 2025 - 11:23 UTC
This incident affected: Web application.