Productboard not loading for a few users
Incident Report for Productboard
Resolved
Our engineering team has now resolved the issue.
Posted Jan 12, 2022 - 22:16 UTC
Identified
Productboard is not loading for a few users. Our engineering team has identified the issue and is working on implementing a fix for this.
Posted Jan 12, 2022 - 21:29 UTC
This incident affected: Web application.