Elevated error rate across Productboard

Incident Report for Productboard

Resolved

This incident has been resolved. We apologize for the disruption and thank you for your patience.
Posted Jun 22, 2026 - 20:53 UTC

Monitoring

A fix has been deployed and we are monitoring recovery. We will post a final update once full functionality is confirmed.
Posted Jun 22, 2026 - 20:36 UTC

Identified

We have identified the cause of this issue and are working on a fix. We will post another update shortly.
Posted Jun 22, 2026 - 20:05 UTC

Investigating

Productboard is experiencing elevated error rate across the application. Our team is investigating and working to restore service as quickly as possible. We will post an update shortly. We apologize for the disruption.
Posted Jun 22, 2026 - 19:34 UTC
This incident affected: Web application (Boards and data).