Navigation not Loading
Incident Report for Productboard
Resolved
We have now resolved the incident, and the navigation menus are now loading.

Thank you for your patience and understanding during this time.
Posted Oct 26, 2023 - 11:12 UTC
Investigating
Some customers are currently experiencing their navigation menu not loading on the left-hand side. We are investigating this issue and will update the status page as soon as possible with an update.
Posted Oct 26, 2023 - 11:05 UTC
This incident affected: Web application.